FIXED: User search fails badly with wildcard character "*"

Questions and Answers : Web site : FIXED: User search fails badly with wildcard character "*"
Message board moderation

To post messages, you must log in.

AuthorMessage
AMDave
Volunteer moderator
Volunteer tester

Send message
Joined: 30 Aug 11
Posts: 41
Credit: 100,018
RAC: 0
Australia
Message 202 - Posted: 11 Oct 2011, 8:08:28 UTC
Last modified: 11 Oct 2011, 8:13:24 UTC

Server software version: 24370 / 11 Oct 2011 | 8:09:00 UTC

Steps to reproduce:
1. main page.
2. click user search
3. enter "*" (without the quotes)

expected result:
All users returned or warning message displayed

actual result:
Warning: Cannot modify header information - headers already sent by (output started at /home/boincadm/projects/yafu/html/inc/util.inc:149) in /home/boincadm/projects/yafu/html/inc/util.inc on line 141

Warning: Cannot modify header information - headers already sent by (output started at /home/boincadm/projects/yafu/html/inc/util.inc:149) in /home/boincadm/projects/yafu/html/inc/util.inc on line 143

Warning: Cannot modify header information - headers already sent by (output started at /home/boincadm/projects/yafu/html/inc/util.inc:149) in /home/boincadm/projects/yafu/html/inc/util.inc on line 144

Warning: Cannot modify header information - headers already sent by (output started at /home/boincadm/projects/yafu/html/inc/util.inc:149) in /home/boincadm/projects/yafu/html/inc/util.inc on line 145

Warning: Cannot modify header information - headers already sent by (output started at /home/boincadm/projects/yafu/html/inc/util.inc:149) in /home/boincadm/projects/yafu/html/inc/util.inc on line 146
Unable to handle request

helpful notes:
the Forum Search handles this character ok.
the Teams search also does this ok and says "No teams were found matching your criteria. Try another search."
assumption -> the User search is missing a bit of code that the other two have.
ID: 202 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile yoyo_rkn
Volunteer moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist

Send message
Joined: 22 Aug 11
Posts: 475
Credit: 5,339,331
RAC: 2,249
Germany
Message 206 - Posted: 13 Oct 2011, 19:51:44 UTC

Fixed by David.
yoyo
ID: 206 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
AMDave
Volunteer moderator
Volunteer tester

Send message
Joined: 30 Aug 11
Posts: 41
Credit: 100,018
RAC: 0
Australia
Message 208 - Posted: 14 Oct 2011, 0:37:01 UTC

Thanks.
I actually found that was a regression.
I found a live older version and tried it there and it gave a warning message that the search string should be at least 3 characters.

I think the next bug will be harder to find.
It's starting to look pretty good from this end.
:)
ID: 208 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Profile yoyo_rkn
Volunteer moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist

Send message
Joined: 22 Aug 11
Posts: 475
Credit: 5,339,331
RAC: 2,249
Germany
Message 210 - Posted: 14 Oct 2011, 7:16:28 UTC

Thanks for your effort.
I'm also checking the German translations. Some translation is still missing.
yoyo
ID: 210 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Questions and Answers : Web site : FIXED: User search fails badly with wildcard character "*"



Copyright © 2011-2018 yoyo